Echo: php-7.2: security update to 7.2.34+e1

medium Tenable Self-Hosted Container Security Plugin ID 477436

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, due to a code logic error,
filtering functions such as filter_var when validating URLs (FILTER_VALIDATE_URL) for certain types of
URLs the function will result in invalid user information (username + password part of URLs) being treated
as valid user information. This may lead to the downstream code accepting invalid URLs as valid and
parsing them incorrectly. (CVE-2024-5458)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2024-5458

Plugin Details

Severity: Medium

ID: 477436

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2024-5458

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 6/4/2024

Reference Information

CVE: CVE-2024-5458