Echo: php-7.2: security update to 7.2.34+e1

medium Tenable Self-Hosted Container Security Plugin ID 477427

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site
attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or
`__Secure-` cookie by PHP applications. (CVE-2022-31629)

Solution

Update the php-7.2 library and its related packages to version 7.2.34+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2022-31629

Plugin Details

Severity: Medium

ID: 477427

Version: Revision 1.1

Type: Local

Published: 10/25/2026

Updated: 10/25/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.51

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS Score Source: CVE-2022-31629

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/25/2026

Vulnerability Publication Date: 9/28/2022

Reference Information

CVE: CVE-2022-31629