Echo: poppler: security update to 25.03.0-5+deb13u4+e3

high Tenable Self-Hosted Container Security Plugin ID 474794

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Poppler 0.42.0 through 26.10.0 contains a stack-based buffer overflow in Decrypt::revision6Hash() that
allows attackers controlling the password to overwrite stack memory when opening AESV3/R6 encrypted PDFs.
Attackers can supply a password longer than 127 bytes through applications using the libpoppler,
libpoppler-glib or C++ API to overflow the K1 and E buffers, crashing the process or corrupting memory.
(CVE-2026-107705)

Solution

Update the poppler library and its related packages to version 25.03.0-5+deb13u4+e3 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-107705

Plugin Details

Severity: High

ID: 474794

Version: Revision 1.1

Type: Local

Published: 10/16/2026

Updated: 10/16/2026

Risk Information

VPR

Risk Factor: Low

Score: 3.5

Percentile: 51.51

CVSS v2

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:C

CVSS Score Source: CVE-2026-107705

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.3

Threat Score: 4.8

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/9/2026

Vulnerability Publication Date: 10/8/2026

Reference Information

CVE: CVE-2026-107705