Echo: compression: security update to 1.8.2

high Tenable Self-Hosted Container Security Plugin ID 473568

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- compression is a Node.js and Express compression middleware. In versions before 1.8.2, when a client
aborts the connection while a compressed response is still being sent, the zlib stream created to compress
that response is never destroyed, so each aborted compressed response leaks its native zlib memory. A
remote unauthenticated attacker can repeatedly open requests and disconnect early, exhausting the
available memory and crashing the server. All applications using compression are affected. The issue is
fixed in compression 1.8.2, and users should upgrade to 1.8.2 or later. (CVE-2026-87776)

Solution

Update the compression library and its related packages to version 1.8.2 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-87776

Plugin Details

Severity: High

ID: 473568

Version: Revision 1.1

Type: Local

Published: 10/7/2026

Updated: 10/13/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.71

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-87776

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/7/2026

Vulnerability Publication Date: 9/11/2026

Reference Information

CVE: CVE-2026-87776