Echo: apache-airflow: security update to 2.8.1rc1

high Tenable Self-Hosted Container Security Plugin ID 460907

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Apache Airflow, versions before 2.8.1, have a vulnerability that allows a potential attacker to poison the
XCom data by bypassing the protection of "enable_xcom_pickling=False" configuration setting resulting in
poisoned data after XCom deserialization. This vulnerability is considered low since it requires a DAG
author to exploit it. Users are recommended to upgrade to version 2.8.1 or later, which fixes this issue.
(CVE-2023-50943)

Solution

Update the apache-airflow library and its related packages to version 2.8.1rc1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2023-50943

Plugin Details

Severity: High

ID: 460907

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.7

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS Score Source: CVE-2023-50943

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.7

Threat Score: 6.6

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 8/12/2026

Vulnerability Publication Date: 1/24/2024

Reference Information

CVE: CVE-2023-50943