Echo: ruby3.1: security update to 3.1.6

medium Tenable Self-Hosted Container Security Plugin ID 459581

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses
an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs,
you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix
these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing
untrusted XML strings. (CVE-2024-39908)

Solution

Update the ruby3.1 library and its related packages to version 3.1.6 or later.

See Also

https://advisory.echohq.com/cve/CVE-2024-39908

Plugin Details

Severity: Medium

ID: 459581

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/2/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2024-39908

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS v4

Risk Factor: Medium

Base Score: 6.9

Threat Score: 2.7

Threat Vector: CVSS:4.0/E:P

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/15/2025

Vulnerability Publication Date: 7/16/2024

Reference Information

CVE: CVE-2024-39908