Echo: libgcrypt20: security update to 1.11.0-7+e6

medium Tenable Self-Hosted Container Security Plugin ID 459420

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted
ECDH ciphertext to gcry_pk_decrypt. (CVE-2026-41989)

Solution

Update the libgcrypt20 library and its related packages to version 1.11.0-7+e6 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-41989

Plugin Details

Severity: Medium

ID: 459420

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/2/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.69

CVSS v2

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 4.1

Vector: CVSS2#AV:L/AC:H/Au:N/C:N/I:C/A:C

CVSS Score Source: CVE-2026-41989

CVSS v3

Risk Factor: Medium

Base Score: 6.7

Temporal Score: 5.8

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 4/24/2026

Vulnerability Publication Date: 4/23/2026

Reference Information

CVE: CVE-2026-41989

IAVA: 2026-A-0403