Echo: samba: security update to 2:3.6.1-2

high Tenable Self-Hosted Container Security Plugin ID 458874

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The chain_reply function in process.c in smbd in Samba before 3.4.8 and 3.5.x before 3.5.2 allows remote
attackers to cause a denial of service (NULL pointer dereference and process crash) via a Negotiate
Protocol request with a certain 0x0003 field value followed by a Session Setup AndX request with a certain
0x8003 field value. (CVE-2010-1635)

Solution

Update the samba library and its related packages to version 2:3.6.1-2 or later.

See Also

https://advisory.echohq.com/cve/CVE-2010-1635

Plugin Details

Severity: High

ID: 458874

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/2/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.18

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2010-1635

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/2/2026

Vulnerability Publication Date: 5/11/2010

Reference Information

CVE: CVE-2010-1635