Echo: samba: security update to 2:3.4.0~pre1-1

critical Tenable Self-Hosted Container Security Plugin ID 458859

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Buffer overflow in the SMB1 packet chaining implementation in the chain_reply function in process.c in
smbd in Samba 3.0.x before 3.3.13 allows remote attackers to cause a denial of service (memory corruption
and daemon crash) or possibly execute arbitrary code via a crafted field in a packet. (CVE-2010-2063)

Solution

Update the samba library and its related packages to version 2:3.4.0~pre1-1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2010-2063

Plugin Details

Severity: Critical

ID: 458859

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/2/2026

Risk Information

VPR

Risk Factor: High

Score: 7.9

Percentile: 99.36

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2010-2063

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/2/2026

Vulnerability Publication Date: 6/16/2010

Exploitable With

Metasploit (Samba chain_reply Memory Corruption (Linux x86))

Reference Information

CVE: CVE-2010-2063