Echo: apache-airflow: security update to 2.8.0

medium Tenable Self-Hosted Container Security Plugin ID 458725

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user
without the variable edit permission, to update a variable. This flaw compromises the integrity of
variable management, potentially leading to unauthorized data modification. Users are recommended to
upgrade to 2.8.0, which fixes this issue (CVE-2023-50783)

Solution

Update the apache-airflow library and its related packages to version 2.8.0 or later.

See Also

https://advisory.echohq.com/cve/CVE-2023-50783

Plugin Details

Severity: Medium

ID: 458725

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.51

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:C/A:N

CVSS Score Source: CVE-2023-50783

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 8/12/2026

Vulnerability Publication Date: 12/21/2023

Reference Information

CVE: CVE-2023-50783