Echo: samba: security update to 2:3.4.7~dfsg-2

medium Tenable Self-Hosted Container Security Plugin ID 458587

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The check_mtab function in client/mount.cifs.c in mount.cifs in smbfs in Samba 3.5.10 and earlier does not
properly verify that the (1) device name and (2) mountpoint strings are composed of valid characters,
which allows local users to cause a denial of service (mtab corruption) via a crafted string. NOTE: this
vulnerability exists because of an incorrect fix for CVE-2010-0547. (CVE-2011-2724)

Solution

Update the samba library and its related packages to version 2:3.4.7~dfsg-2 or later.

See Also

https://advisory.echohq.com/cve/CVE-2011-2724

Plugin Details

Severity: Medium

ID: 458587

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/2/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.18

CVSS v2

Risk Factor: Low

Base Score: 1.2

Temporal Score: 0.9

Vector: CVSS2#AV:L/AC:H/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2011-2724

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 6/2/2026

Vulnerability Publication Date: 2/19/2010

Reference Information

CVE: CVE-2011-2724