Echo: apache-airflow: security update to 3.1.8

medium Tenable Self-Hosted Container Security Plugin ID 457034

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency
graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG
Dependencies permission to enumerate DAGs they are not authorized to view. Users are recommended to
upgrade to Apache Airflow 3.1.8 or later, which resolves this issue. (CVE-2026-28563)

Solution

Update the apache-airflow library and its related packages to version 3.1.8 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-28563

Plugin Details

Severity: Medium

ID: 457034

Version: Revision 1.1

Type: Local

Published: 10/2/2026

Updated: 10/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

CVSS Score Source: CVE-2026-28563

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 7/1/2026

Vulnerability Publication Date: 3/17/2026

Reference Information

CVE: CVE-2026-28563