Google: dev-libs/glib: security update to 18244.582.40

critical Tenable Self-Hosted Container Security Plugin ID 451934

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- A flaw was found in GLib (Gnome Lib). This vulnerability allows a remote attacker to cause heap
corruption, leading to a denial of service or potential code execution via a buffer-underflow in the
GVariant parser when processing maliciously crafted input strings. (CVE-2025-14087)

Solution

Update the dev-libs/glib library and its related packages to version 18244.582.40 or later.

See Also

https://storage.googleapis.com/cos-oval-vulnerability-feed/cos-113.oval.xml.tar.gz

Plugin Details

Severity: Critical

ID: 451934

Version: Revision 1.1

Type: Local

Published: 10/1/2026

Updated: 10/1/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 57.48

Vendor

Vendor Severity: MEDIUM

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2025-14087

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 12/10/2025

Reference Information

CVE: CVE-2025-14087