Google: dev-libs/libxml2: security update to 18244.291.20

critical Tenable Self-Hosted Container Security Plugin ID 451877

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In libxml2 2.11 before 2.11.9, 2.12 before 2.12.9, and 2.13 before 2.13.3, the SAX parser can produce
events for external entities even if custom SAX handlers try to override entity content (by setting
"checked"). This makes classic XXE attacks possible. (CVE-2024-40896)

Solution

Update the dev-libs/libxml2 library and its related packages to version 18244.291.20 or later.

See Also

https://storage.googleapis.com/cos-oval-vulnerability-feed/cos-113.oval.xml.tar.gz

Plugin Details

Severity: Critical

ID: 451877

Version: Revision 1.1

Type: Local

Published: 10/1/2026

Updated: 10/1/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.37

Vendor

Vendor Severity: HIGH

CVSS v2

Risk Factor: High

Base Score: 9.4

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:C

CVSS Score Source: CVE-2024-40896

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 8/24/2024

Reference Information

CVE: CVE-2024-40896