Google: dev-libs/glib: security update to 17927.0.0

high Tenable Self-Hosted Container Security Plugin ID 451481

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- A flaw was found in GLib. The GVariant deserialization code is vulnerable to a heap buffer overflow
introduced by the fix for CVE-2023-32665. This bug does not affect any released version of GLib, but does
affect GLib distributors who followed the guidance of GLib developers to backport the initial fix for
CVE-2023-32665. (CVE-2023-32643)

Solution

Update the dev-libs/glib library and its related packages to version 17927.0.0 or later.

See Also

https://storage.googleapis.com/cos-oval-vulnerability-feed/cos-113.oval.xml.tar.gz

Plugin Details

Severity: High

ID: 451481

Version: Revision 1.1

Type: Local

Published: 10/1/2026

Updated: 10/1/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 57.12

Vendor

Vendor Severity: LOW

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-32643

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 6/7/2023

Reference Information

CVE: CVE-2023-32643