SCA: security update for GeoNode (GHSA-9fpx-fr6j-2vh6)

high Tenable Cloud Security Plugin ID 478637

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- GeoNode is a geospatial content management system, a platform for the management and publication of
geospatial data. Prior to 5.1.0, a crafted vector file layer name supplied during upload allows a low-
privileged remote user to inject shell syntax and execute arbitrary operating-system commands on the
GeoNode server. This issue is fixed in version 5.1.0. (CVE-2026-33050)

Solution

Update the GeoNode library and its related packages to version 5.1.0 or later.

See Also

https://github.com/advisories/GHSA-9fpx-fr6j-2vh6

Plugin Details

Severity: High

ID: 478637

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 11/7/2026

Updated: 11/7/2026

Risk Information

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-33050

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 11/6/2026

Vulnerability Publication Date: 11/6/2026

Reference Information

CVE: CVE-2026-33050

cwe: CWE-78