Alpine: zlib: security update to 1.4-r0

critical Tenable Cloud Security Plugin ID 478632

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability in OSGeo gdal
(frmts/zlib/contrib/infback9 modules). This vulnerability is associated with program files inftree9.C‎.
This issue affects gdal: before 3.11.0. (CVE-2026-4738)

Solution

Update the zlib library and its related packages to version 1.4-r0 or later.

See Also

https://security.alpinelinux.org/vuln/CVE-2026-4738

Plugin Details

Severity: Critical

ID: 478632

Version: Revision 1.1

Type: Local

Published: 11/7/2026

Updated: 11/7/2026

Supported Sensors: Agentless Assessment

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 58.52

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2026-4738

CVSS v3

Risk Factor: High

Base Score: 8.4

Temporal Score: 7.3

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: Critical

Base Score: 9.4

Threat Score: 7.7

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 3/24/2026

Reference Information

CVE: CVE-2026-4738