Chainguard: crossplane-provider-terraform: security update to 1.2.0-r8

medium Tenable Cloud Security Plugin ID 478612

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its
archive decompression handling that may allow a crafted archive to cause extracted files to be created
with elevated permission bits. Where extraction is performed by a privileged user, this may allow a local
actor to obtain the privileges of the extracting process. This vulnerability (CVE-2026-88922) is fixed in
go-getter 1.8.9 and 2.2.4. (CVE-2026-88922)

Solution

Update the crossplane-provider-terraform library and its related packages to version 1.2.0-r8 or later.

Plugin Details

Severity: Medium

ID: 478612

Version: Revision 1.1

Type: Local

Published: 11/6/2026

Updated: 11/6/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 58.51

CVSS v2

Risk Factor: Medium

Base Score: 6

Temporal Score: 4.4

Vector: CVSS2#AV:L/AC:H/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-88922

CVSS v3

Risk Factor: Medium

Base Score: 6.7

Temporal Score: 5.8

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/15/2026

Reference Information

CVE: CVE-2026-88922