Alpine: openssh: security update to 9.1_p1-r7

high Tenable Cloud Security Plugin ID 478604

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- sshd in OpenSSH before 10.6p2 on Linux, when musl libc is used without PAM, lacks a workaround for a
password authentication bypass (related to misinterpretation of whether a string is intended to be a
password hash). For some configurations of accounts, any password between 256 and 1024 characters
succeeds. An example of a platform using musl libc without PAM is Alpine Linux. (CVE-2026-123158)

Solution

Update the openssh library and its related packages to version 9.1_p1-r7 or later.

See Also

https://security.alpinelinux.org/vuln/CVE-2026-123158

Plugin Details

Severity: High

ID: 478604

Version: Revision 1.1

Type: Local

Published: 11/6/2026

Updated: 11/6/2026

Supported Sensors: Agentless Assessment

Risk Information

VPR

Risk Factor: Medium

Score: 6.9

Percentile: 96.3

CVSS v2

Risk Factor: High

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-123158

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 11/5/2026

Reference Information

CVE: CVE-2026-123158