Chainguard: geoserver-2.28-community: security update to 2.28.6-r3

high Tenable Cloud Security Plugin ID 478590

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All.
An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and
searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an
attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ
Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7;
Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version
6.2.7 or 5.19.8, which fixes the issue. (CVE-2026-49434)

Solution

Update the geoserver-2.28-community library and its related packages to version 2.28.6-r3 or later.

Plugin Details

Severity: High

ID: 478590

Version: Revision 1.1

Type: Local

Published: 11/6/2026

Updated: 11/6/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.75

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS Score Source: CVE-2026-49434

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 6/30/2026

Reference Information

CVE: CVE-2026-49434