Echo: openssl-1.0.1g: security update to 1.0.1g+e1

critical Tenable Cloud Security Plugin ID 478580

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The fmtstr function in crypto/bio/b_print.c in OpenSSL 1.0.1 before 1.0.1s and 1.0.2 before 1.0.2g
improperly calculates string lengths, which allows remote attackers to cause a denial of service (overflow
and out-of-bounds read) or possibly have unspecified other impact via a long string, as demonstrated by a
large amount of ASN.1 data, a different vulnerability than CVE-2016-2842. (CVE-2016-0799)

Solution

Update the openssl-1.0.1g library and its related packages to version 1.0.1g+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2016-0799

Plugin Details

Severity: Critical

ID: 478580

Version: Revision 1.1

Type: Local

Published: 11/5/2026

Updated: 11/5/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 57.12

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2016-0799

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 11/5/2026

Vulnerability Publication Date: 2/29/2016

Reference Information

CVE: CVE-2016-0799