Echo: openssl-1.0.1g: security update to 1.0.1g+e1

critical Tenable Cloud Security Plugin ID 478571

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The BN_bn2dec function in crypto/bn/bn_print.c in OpenSSL before 1.1.0 does not properly validate division
results, which allows remote attackers to cause a denial of service (out-of-bounds write and application
crash) or possibly have unspecified other impact via unknown vectors. (CVE-2016-2182)

Solution

Update the openssl-1.0.1g library and its related packages to version 1.0.1g+e1 or later.

See Also

https://access.redhat.com/errata/RHSA-2018:2185

https://access.redhat.com/errata/RHSA-2018:2186

https://access.redhat.com/errata/RHSA-2018:2187

https://advisory.echohq.com/cve/CVE-2016-2182

Plugin Details

Severity: Critical

ID: 478571

Version: Revision 1.1

Type: Local

Published: 11/5/2026

Updated: 11/5/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 57.12

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2016-2182

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 11/5/2026

Vulnerability Publication Date: 6/1/2016

Reference Information

CVE: CVE-2016-2182