Echo: openssl-1.0.1g: security update to 1.0.1g+e1

medium Tenable Cloud Security Plugin ID 478548

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- The ssl3_get_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1
before 1.0.1k allows remote SSL servers to conduct RSA-to-EXPORT_RSA downgrade attacks and facilitate
brute-force decryption by offering a weak ephemeral RSA key in a noncompliant role, related to the "FREAK"
issue. NOTE: the scope of this CVE is only client code based on OpenSSL, not EXPORT_RSA issues associated
with servers or other TLS implementations. (CVE-2015-0204)

Solution

Update the openssl-1.0.1g library and its related packages to version 1.0.1g+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2015-0204

Plugin Details

Severity: Medium

ID: 478548

Version: Revision 1.1

Type: Local

Published: 11/5/2026

Updated: 11/5/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2015-0204

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 11/5/2026

Vulnerability Publication Date: 10/21/2014

Reference Information

CVE: CVE-2015-0204