Echo: openssl-1.0.1g: security update to 1.0.1g+e1

high Tenable Cloud Security Plugin ID 478506

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Memory leak in d1_both.c in the DTLS implementation in OpenSSL 0.9.8 before 0.9.8zb, 1.0.0 before 1.0.0n,
and 1.0.1 before 1.0.1i allows remote attackers to cause a denial of service (memory consumption) via
zero-length DTLS fragments that trigger improper handling of the return value of a certain insert
function. (CVE-2014-3507)

Solution

Update the openssl-1.0.1g library and its related packages to version 1.0.1g+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2014-3507

Plugin Details

Severity: High

ID: 478506

Version: Revision 1.1

Type: Local

Published: 11/5/2026

Updated: 11/5/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.18

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2014-3507

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 11/5/2026

Vulnerability Publication Date: 8/6/2014

Reference Information

CVE: CVE-2014-3507