Echo: curl-7.69.1: security update to 7.69.1+e2

medium Tenable Cloud Security Plugin ID 478452

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- An authentication bypass vulnerability exists libcurl <8.0.0 in the connection reuse feature which can
reuse previously established connections with incorrect user permissions due to a failure to check for
changes in the CURLOPT_GSSAPI_DELEGATION option. This vulnerability affects krb5/kerberos/negotiate/GSSAPI
transfers and could potentially result in unauthorized access to sensitive information. The safest option
is to not reuse connections if the CURLOPT_GSSAPI_DELEGATION option has been changed. (CVE-2023-27536)

Solution

Update the curl-7.69.1 library and its related packages to version 7.69.1+e2 or later.

See Also

https://advisory.echohq.com/cve/CVE-2023-27536

Plugin Details

Severity: Medium

ID: 478452

Version: Revision 1.1

Type: Local

Published: 11/5/2026

Updated: 11/5/2026

Risk Information

VPR

Risk Factor: Medium

Score: 5.7

Percentile: 96.65

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2023-27536

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/5/2026

Vulnerability Publication Date: 3/20/2023

Reference Information

CVE: CVE-2023-27536