SCA: security update for org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina (GHSA-5v3h-fjv2-54fg)

medium Tenable Cloud Security Plugin ID 478357

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the
default servlet ignoring any method or method omission configured as part of the constraint. This issue
affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1
through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached
end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or
9.0.119, which fix the issue. (CVE-2026-55956)

Solution

Update the org.apache.tomcat.embed:tomcat-embed-core library and its related packages to version 10.1.56 or later.

See Also

https://github.com/advisories/GHSA-5v3h-fjv2-54fg

Plugin Details

Severity: Medium

ID: 478357

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 11/4/2026

Updated: 11/4/2026

Risk Information

VPR

Risk Factor: Low

Score: 2.1

Percentile: 7.98

Vendor

Vendor Severity: Medium

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2026-55956

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 6/29/2026

Vulnerability Publication Date: 6/22/2026

Reference Information

CVE: CVE-2026-55956

cwe: CWE-285