SCA: security update for org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina (GHSA-7895-gffq-w6jq)

high Tenable Cloud Security Plugin ID 478355

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured
to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct
password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36,
from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are
recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue. (CVE-2026-55957)

Solution

Update the org.apache.tomcat.embed:tomcat-embed-core library and its related packages to version 10.1.37 or later.

See Also

https://github.com/advisories/GHSA-7895-gffq-w6jq

Plugin Details

Severity: High

ID: 478355

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 11/4/2026

Updated: 11/4/2026

Risk Information

VPR

Risk Factor: Low

Score: 2.8

Percentile: 22.2

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: High

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-55957

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 6/29/2026

Vulnerability Publication Date: 3/6/2025

Reference Information

CVE: CVE-2026-55957

cwe: CWE-304