Chainguard: jenkins-2.580: security update to 2.580.2-r0

high Tenable Cloud Security Plugin ID 478327

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Jenkins 2.587 and earlier, LTS 2.580.1 and earlier provides an HTTP endpoint that loads agents by name
without validating the name, allowing attackers with Overall/Read permission to load any config.xml file
on the controller file system as an agent configuration, and to overwrite an arbitrary config.xml file
when that agent is saved, potentially resulting in arbitrary code execution. (CVE-2026-117616)

Solution

Update the jenkins-2.580 library and its related packages to version 2.580.2-r0 or later.

Plugin Details

Severity: High

ID: 478327

Version: Revision 1.3

Type: Local

Published: 11/4/2026

Updated: 11/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 58.57

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-117616

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 10/28/2026

Reference Information

CVE: CVE-2026-117616