Chainguard: jenkins-2.580: security update to 2.580.2-r0

high Tenable Cloud Security Plugin ID 478324

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Jenkins 2.587 and earlier, LTS 2.580.1 and earlier converts the launch commands in older agent
configurations into launchers provided by the Command Agent Launcher Plugin without checking whether they
have been approved by an administrator, allowing attackers with Agent/Configure permission to execute
arbitrary code in the context of the Jenkins controller JVM. (CVE-2026-117614)

Solution

Update the jenkins-2.580 library and its related packages to version 2.580.2-r0 or later.

Plugin Details

Severity: High

ID: 478324

Version: Revision 1.3

Type: Local

Published: 11/4/2026

Updated: 11/5/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 58.56

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-117614

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 10/28/2026

Reference Information

CVE: CVE-2026-117614