SCA: security update for next (GHSA-26hh-7cqf-hhc6)

high Tenable Cloud Security Plugin ID 478309

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and
16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack.
This vulnerability is fixed in 15.5.18 and 16.2.6. (CVE-2026-45109)

Solution

Update the next library and its related packages to version 15.5.18 or later.

See Also

https://github.com/advisories/GHSA-26hh-7cqf-hhc6

Plugin Details

Severity: High

ID: 478309

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 11/4/2026

Updated: 11/4/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.61

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2026-45109

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 5/11/2026

Vulnerability Publication Date: 5/11/2026

Reference Information

CVE: CVE-2026-45109