SCA: security update for puma (GHSA-2vqw-3mp8-cgmx)

high Tenable Cloud Security Plugin ID 478213

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Puma is a Ruby/Rack web server built for parallelism. From 5.5.0 until 7.2.1 and 8.0.2, Puma is vulnerable
to source IP spoofing when set_remote_address proxy_protocol: :v1 is enabled and persistent connections
are used because Puma incorrectly re-parses PROXY protocol headers after each keep-alive request on the
same connection, allowing an attacker to inject a second PROXY header and overwrite REMOTE_ADDR. This
issue is fixed in versions 7.2.1 and 8.0.2. (CVE-2026-47737)

Solution

Update the puma library and its related packages to version 7.2.1 or later.

See Also

https://github.com/advisories/GHSA-2vqw-3mp8-cgmx

Plugin Details

Severity: High

ID: 478213

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 11/3/2026

Updated: 11/3/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.77

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS Score Source: CVE-2026-47737

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 6/9/2026

Vulnerability Publication Date: 6/9/2026

Reference Information

CVE: CVE-2026-47737