Chainguard: multiple py3-sqlparse packages: security update to 0.6.1-r0

high Tenable Cloud Security Plugin ID 478179

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- sqlparse through 0.6.0 contains a PHP code injection vulnerability that allows attackers to inject PHP
expressions by supplying SQL text containing unescaped dollar signs. Attackers can embed ${expr} or
{${expr}} sequences that OutputPHPFilter places in double-quoted strings, executing arbitrary PHP code
when the generated snippet runs. (CVE-2026-112307)

Solution

Update the py3-sqlparse library and its related packages to version 0.6.1-r0 or later.

Plugin Details

Severity: High

ID: 478179

Version: Revision 1.1

Type: Local

Published: 11/2/2026

Updated: 11/2/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.5

Percentile: 57.85

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:P

CVSS Score Source: CVE-2026-112307

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.4

Threat Score: 5.9

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 10/19/2026

Reference Information

CVE: CVE-2026-112307