Echo: sqlite3: security update to 3.46.1-7+e9

low Tenable Cloud Security Plugin ID 478167

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- SQLite before 3.54.0 contains an authorization bypass vulnerability in lookupName() that invokes the
authorizer only for the first joined table's USING column. Attackers able to submit SQL can query a shared
USING column in a RIGHT or FULL JOIN to read columns denied via sqlite3_set_authorizer() SQLITE_READ
restrictions. (CVE-2026-119377)

Solution

Update the sqlite3 library and its related packages to version 3.46.1-7+e9 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-119377

Plugin Details

Severity: Low

ID: 478167

Version: Revision 1.1

Type: Local

Published: 11/2/2026

Updated: 11/2/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

CVSS v2

Risk Factor: Low

Base Score: 1

Temporal Score: 0.7

Vector: CVSS2#AV:L/AC:H/Au:S/C:P/I:N/A:N

CVSS Score Source: CVE-2026-119377

CVSS v3

Risk Factor: Low

Base Score: 2.5

Temporal Score: 2.2

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: Low

Base Score: 2

Threat Score: 0.4

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 11/1/2026

Vulnerability Publication Date: 10/30/2026

Reference Information

CVE: CVE-2026-119377