Description
There are packages installed that are affected by a vulnerability referenced in the following CVE:
- Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior
to 1.4.1, node-forge parsed deprecated extension OIDs 2.5.29.10 and 2.5.29.13 as basicConstraints, and
pki.verifyCertificateChain() used the first extension with that name. Exploitation requires a CA trusted
by the application to issue a certificate carrying an attacker-supplied deprecated-OID extension, commonly
because the CA copies extensions from a certificate signing request. By placing a permissive deprecated
extension before the genuine 2.5.29.19 basicConstraints extension, the certificate holder could have the
certificate accepted as a CA and issue certificates for arbitrary names, enabling server or client
impersonation. If the issuing CA adds a keyUsage extension without keyCertSign, node-forge rejects the
chain. This issue is fixed in version 1.4.1. (CVE-2026-119190)
Solution
Update the kubeflow-centraldashboard library and its related packages to version 2.0.0-r8 or later.
Plugin Details
Risk Information
Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:N
Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C
Vulnerability Information
Exploit Ease: No known exploits are available
Vulnerability Publication Date: 10/29/2026