SCA: security update for graphql-core (GHSA-mpqx-q82w-9x46)

high Tenable Cloud Security Plugin ID 478100

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- GraphQL-core is a Python port of the GraphQL.js reference implementation. From 3.3.0a3 until 3.3.1,
validate() reuses a module-level ValidationAbortedError when a document exceeds max_errors. Python appends
frames to the reused exception's traceback on every raise, retaining each document, validation context,
and error set for the process lifetime. An unauthenticated client can repeatedly submit a small document
with more than 100 validation errors to cause unbounded memory growth before query execution, eventually
exhausting worker memory without disclosing or modifying data. This issue is fixed in version 3.3.1.
(CVE-2026-119286)

Solution

Update the graphql-core library and its related packages to version 3.3.1 or later.

See Also

https://github.com/advisories/GHSA-mpqx-q82w-9x46

Plugin Details

Severity: High

ID: 478100

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 10/31/2026

Updated: 10/31/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.73

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-119286

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/30/2026

Vulnerability Publication Date: 10/29/2026

Reference Information

CVE: CVE-2026-119286