Chainguard: multiple postgis-14 packages: security update to 3.7.0-r0

high Tenable Cloud Security Plugin ID 478039

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- PostGIS before 3.7.0beta2 contains an out-of-bounds read vulnerability that allows attackers to cause
memory disclosure or a server crash by supplying a malformed FlatGeobuf buffer. The FlatGeobuf property
metadata decoder verifies that a string length field is present but fails to verify that the subsequent
string body is contained within the supplied buffer before materializing it into a SQL-visible value,
enabling memory disclosure or denial of service. (CVE-2026-73515)

Solution

Update the postgis-14 library and its related packages to version 3.7.0-r0 or later.

Plugin Details

Severity: High

ID: 478039

Version: Revision 1.1

Type: Local

Published: 10/31/2026

Updated: 10/31/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.43

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:N/A:C

CVSS Score Source: CVE-2026-73515

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 7.2

Threat Score: 5.1

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 8/13/2026

Reference Information

CVE: CVE-2026-73515