Chainguard: py3.14-airflow-3: security update to 3.3.2-r13

high Tenable Cloud Security Plugin ID 478023

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until
1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-
rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata
containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that
ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting
administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through
1.90.x require EXPERIMENTAL_UI_LOGIN to be enabled, while versions after 1.91.0 are exploitable in the
default configuration. This issue was fixed in LiteLLM 1.100.4, 1.101.3, 1.102.2, 1.103.1, and
1.104.0-rc.2. (CVE-2026-114612)

Solution

Update the py3.14-airflow-3 library and its related packages to version 3.3.2-r13 or later.

Plugin Details

Severity: High

ID: 478023

Version: Revision 1.1

Type: Local

Published: 10/30/2026

Updated: 10/30/2026

Risk Information

VPR

Risk Factor: Medium

Score: 5

Percentile: 92.98

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-114612

CVSS v3

Risk Factor: Critical

Base Score: 9.9

Temporal Score: 8.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 7.7

Threat Score: 6.8

Threat Vector: CVSS:4.0/E:P

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 10/22/2026

Reference Information

CVE: CVE-2026-114612