Chainguard: multiple automq packages: security update to 1.7.4-r4

high Tenable Cloud Security Plugin ID 477962

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In Apache Thrift all versions up to and including 0.12.0, a server or client may run into an endless loop
when feed with specific input data. Because the issue had already been partially fixed in version 0.11.0,
depending on the installed version it affects only certain language bindings. (CVE-2019-0205)

Solution

Update the automq library and its related packages to version 1.7.4-r4 or later.

Plugin Details

Severity: High

ID: 477962

Version: Revision 1.1

Type: Local

Published: 10/30/2026

Updated: 10/30/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.67

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2019-0205

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 10/28/2019

Reference Information

CVE: CVE-2019-0205