Chainguard: vllm-omni-cuda-13.0: security update to 0.32.0-r0

medium Tenable Cloud Security Plugin ID 477955

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- vLLM is an inference and serving engine for large language models. Prior to 0.32.0, vllm/tokenizers/hf.py
computes max_token_id with an off-by-one upper bound, allowing a pre-tokenized prompt ID equal to the
vocabulary size to pass validation. For a tensor-parallel size of one and an exact multiple-of-64
vocabulary, VocabParallelEmbedding.forward does not mask that value before F.embedding uses it, causing a
CUDA device-side assertion and terminating the engine. This issue is fixed in version 0.32.0.
(CVE-2026-115916)

Solution

Update the vllm-omni-cuda-13.0 library and its related packages to version 0.32.0-r0 or later.

Plugin Details

Severity: Medium

ID: 477955

Version: Revision 1.1

Type: Local

Published: 10/30/2026

Updated: 10/30/2026

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.72

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

CVSS Score Source: CVE-2026-115916

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 10/26/2026

Reference Information

CVE: CVE-2026-115916