Description
There are packages installed that are affected by a vulnerability referenced in the following CVE:
- vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible
server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious
web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal
network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU
resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials
are disabled by default, and deployments requiring bearer authentication are exposed only when the caller
already has a usable token. This issue is fixed in version 0.32.0. (CVE-2026-115917)
Solution
Update the vllm-omni-cuda-13.0 library and its related packages to version 0.32.0-r0 or later.
Plugin Details
Risk Information
Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N
Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C
Vulnerability Information
Exploit Ease: No known exploits are available
Vulnerability Publication Date: 10/26/2026