Chainguard: vllm-omni-cuda-13.0: security update to 0.32.0-r0

high Tenable Cloud Security Plugin ID 477948

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- vLLM is an inference and serving engine for large language models. Prior to 0.32.0, an authenticated
caller can place forged shared-memory address and monotonic_id values in public multimodal
features.kwargs_data. In scale-out deployments with shared-memory multimodal caching enabled, workers
trust those values and pass attacker-selected bytes to pickle.loads(), allowing arbitrary Python execution
even when insecure serialization is disabled. This issue is fixed in version 0.32.0. (CVE-2026-115912)

Solution

Update the vllm-omni-cuda-13.0 library and its related packages to version 0.32.0-r0 or later.

Plugin Details

Severity: High

ID: 477948

Version: Revision 1.1

Type: Local

Published: 10/30/2026

Updated: 10/30/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 58.58

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-115912

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 10/26/2026

Reference Information

CVE: CVE-2026-115912