Echo: expat: security update to 2.9.0-1+e5

high Tenable Cloud Security Plugin ID 477896

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- libexpat through 2.9.0 contains a signed integer overflow vulnerability in storeAtts() in lib/xmlparse.c
that allows attackers to trigger out-of-bounds writes via oversized attribute counts. Attackers can supply
a multi-gigabyte document with a start tag carrying over 2^30 attributes to overflow attIndex and
nPrefixes, crashing applications or corrupting heap memory. (CVE-2026-118370)

Solution

Update the expat library and its related packages to version 2.9.0-1+e5 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-118370

Plugin Details

Severity: High

ID: 477896

Version: Revision 1.1

Type: Local

Published: 10/29/2026

Updated: 10/29/2026

Risk Information

VPR

Risk Factor: Low

Score: 3.5

Percentile: 51.44

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2026-118370

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.2

Threat Score: 4.6

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/28/2026

Vulnerability Publication Date: 10/28/2026

Reference Information

CVE: CVE-2026-118370