Chainguard: multiple openjdk-17-openj9 packages: security update to 0.63.0-r0

high Tenable Cloud Security Plugin ID 477863

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- In Eclipse OpenJ9 versions prior to 0.63.0, the JITServer component fails to perform cross-field
validation on attacker-controlled `_size`, `_paddingSize`, and `_dataOffset` fields during
`DataDescriptor` message deserialization. An unauthenticated remote attacker can send a crafted network
payload that triggers an unsigned integer underflow in `DataDescriptor::getPayloadSize()` and
`DataDescriptor::getNextDescriptor()`. This results in an out-of-bounds heap read and an immediate process
crash (SIGSEGV), causing a denial of service. (CVE-2026-111075)

Solution

Update the openjdk-17-openj9 library and its related packages to version 0.63.0-r0 or later.

Plugin Details

Severity: High

ID: 477863

Version: Revision 1.3

Type: Local

Published: 10/29/2026

Updated: 10/31/2026

Supported Sensors: Tenable Cloud Security, Tenable Self-Hosted Container Security

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.7

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2026-111075

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.7

Threat Score: 6.6

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 10/21/2026

Reference Information

CVE: CVE-2026-111075