SCA: security update for @highcharts/grid-lite, @highcharts/grid-pro (GHSA-r5wg-q8fc-p6w2)

high Tenable Cloud Security Plugin ID 477831

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid
writes pagination language strings into the DOM as markup instead of text. An attacker who controls the
Grid language configuration can provide elements with event handlers, which execute in the hosting page
origin when pagination controls render. Exploitation requires pagination to be enabled but does not
require additional user interaction. This issue is fixed in 3.2.0. (CVE-2026-118254)

Solution

Update the @highcharts/grid-lite library and its related packages to version 3.2.0 or later.

See Also

https://github.com/advisories/GHSA-r5wg-q8fc-p6w2

Plugin Details

Severity: High

ID: 477831

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 10/29/2026

Updated: 10/29/2026

Risk Information

VPR

Risk Factor: Low

Score: 2.1

Percentile: 8.29

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2026-118254

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.6

Threat Score: 6.2

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/28/2026

Vulnerability Publication Date: 10/28/2026

Reference Information

CVE: CVE-2026-118254

cwe: CWE-79