SCA: security update for i18next-http-backend (GHSA-3cmx-xjww-583x)

low Tenable Cloud Security Plugin ID 477801

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- i18next-http-backend is a backend layer for i18next that loads translation resources in Node.js, browsers,
and Deno. Prior to 4.0.4, interpolateUrl inserts unencoded language and namespace values into loadPath or
addPath templates without rejecting ampersand (&), equals (=), or semicolon (;) query separators. When a
template places lng or ns in the query string and an attacker controls that value, the attacker can add or
override parameters on browser or server-side translation requests, potentially exposing other namespaces
or tenants or changing backend behavior through the application's network position and credentials. This
vulnerability is the result of an incomplete fix for CVE-2026-41691. This issue is fixed in version 4.0.4.
(CVE-2026-118258)

Solution

Update the i18next-http-backend library and its related packages to version 4.0.4 or later.

See Also

https://github.com/advisories/GHSA-3cmx-xjww-583x

Plugin Details

Severity: Low

ID: 477801

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 10/29/2026

Updated: 10/29/2026

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

Vendor

Vendor Severity: Low

CVSS v2

Risk Factor: Low

Base Score: 2.6

Temporal Score: 1.9

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2026-118258

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/28/2026

Vulnerability Publication Date: 10/28/2026

Reference Information

CVE: CVE-2026-118258

cwe: CWE-74