SCA: security update for langgraph-api (GHSA-4hm6-w6qq-w73v)

high Tenable Cloud Security Plugin ID 477780

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- langgraph-api implements the LangGraph API for rapid development and testing. From 0.1.2 until 0.15.0,
JavaScript or TypeScript custom authentication Store authorization handlers can return a rewritten
namespace that is not carried across the runtime boundary and applied before the Store operation. An
authenticated user can therefore access another user's Store namespace when a deployment relies on
namespace rewriting for isolation, allowing unauthorized reads, overwrites, searches, or deletions. Python
custom authentication and handlers that reject unauthorized namespaces instead of rewriting them are not
affected. This issue is fixed in version 0.15.0. (CVE-2026-118668)

Solution

Update the langgraph-api library and its related packages to version 0.15.0 or later.

See Also

https://github.com/advisories/GHSA-4hm6-w6qq-w73v

Plugin Details

Severity: High

ID: 477780

Version: Revision 1.1

Type: Local

Family: SCA Checks

Published: 10/29/2026

Updated: 10/29/2026

Risk Information

VPR

Risk Factor: Low

Score: 3.5

Percentile: 51.45

Vendor

Vendor Severity: High

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

CVSS Score Source: CVE-2026-118668

CVSS v3

Risk Factor: High

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS v4

Risk Factor: High

Base Score: 8.6

Threat Score: 6.2

Threat Vector: CVSS:4.0/E:U

Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Vulnerability Information

Exploit Ease: No known exploits are available

Patch Publication Date: 10/28/2026

Vulnerability Publication Date: 10/28/2026

Reference Information

CVE: CVE-2026-118668