Echo: firebird4.0: security update to 4.0.5.3140.ds6-17+deb13u1+e1

high Tenable Cloud Security Plugin ID 477745

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and
3.0.14, when processing CNCT_specific_data segments during authentication, the server assumes segments
arrive in strictly ascending order. If segments arrive out of order, the Array class's grow() method
computes a negative size value, causing a SIGSEGV crash. An unauthenticated attacker who knows only the
server's IP and port can exploit this to crash the server. This issue has been fixed in versions 5.0.4,
4.0.7 and 3.0.14. (CVE-2026-27890)

Solution

Update the firebird4.0 library and its related packages to version 4.0.5.3140.ds6-17+deb13u1+e1 or later.

See Also

https://advisory.echohq.com/cve/CVE-2026-27890

Plugin Details

Severity: High

ID: 477745

Version: Revision 1.1

Type: Local

Published: 10/29/2026

Updated: 10/29/2026

Risk Information

VPR

Risk Factor: Low

Score: 3.5

Percentile: 51.95

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:C

CVSS Score Source: CVE-2026-27890

CVSS v3

Risk Factor: High

Base Score: 8.2

Temporal Score: 7.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/28/2026

Vulnerability Publication Date: 4/17/2026

Reference Information

CVE: CVE-2026-27890