Chainguard: ecpg-17, multiple libecpg-17 packages, multiple postgresql-17 packages: security update to 17.11-r0

high Tenable Cloud Security Plugin ID 477719

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Type confusion regarding input of PostgreSQL ctid data type selectivity estimator allows an object creator
to view a calculation derived from the value of an arbitrary 4-byte span of memory, via a chosen non-ctid
input. While the calculation loses precision, substantial memory value recovery appears possible. Versions
before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected. (CVE-2026-14668)

Solution

Update the ecpg-17 library and its related packages to version 17.11-r0 or later.

Plugin Details

Severity: High

ID: 477719

Version: Revision 1.1

Type: Local

Published: 10/28/2026

Updated: 10/28/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.5

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:N/A:C

CVSS Score Source: CVE-2026-14668

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 8/13/2026

Reference Information

CVE: CVE-2026-14668