Chainguard: ecpg-16, multiple libecpg-16 packages, multiple postgresql-16 packages: security update to 16.15-r0

high Tenable Cloud Security Plugin ID 477717

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Heap buffer overflow in PostgreSQL regexp allows the query author to execute arbitrary code as the
operating system user running the database, via text that would not pass encoding validation. This shares
heritage with CVE-2026-2006, but this case involved unanticipated data growth when round-tripped through
pg_wchar. Versions before PostgreSQL 18.6, 17.11, 16.15, 15.19, and 14.24 are affected. (CVE-2026-14664)

Solution

Update the ecpg-16 library and its related packages to version 16.15-r0 or later.

Plugin Details

Severity: High

ID: 477717

Version: Revision 1.1

Type: Local

Published: 10/28/2026

Updated: 10/28/2026

Risk Information

VPR

Risk Factor: Medium

Score: 4.9

Percentile: 58.17

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2026-14664

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 8/13/2026

Reference Information

CVE: CVE-2026-14664