Chainguard: libecpg-15, multiple postgresql-15 packages: security update to 15.19-r0

high Tenable Cloud Security Plugin ID 477713

Description

There are packages installed that are affected by a vulnerability referenced in the following CVE:

- Missing authorization in PostgreSQL logical decoding allows a non-superuser holding REPLICATION privilege
to dlopen any file visible to the operating system account running the server, via the choice of logical
decoding plugin. This in turn runs arbitrary code as that account. Versions before PostgreSQL 18.6, 17.11,
16.15, 15.19, and 14.24 are affected. (CVE-2026-6471)

Solution

Update the libecpg-15 library and its related packages to version 15.19-r0 or later.

Plugin Details

Severity: High

ID: 477713

Version: Revision 1.1

Type: Local

Published: 10/28/2026

Updated: 10/28/2026

Risk Information

VPR

Risk Factor: High

Score: 7.7

Percentile: 98.93

CVSS v2

Risk Factor: High

Base Score: 8.3

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:M/C:C/I:C/A:C

CVSS Score Source: CVE-2026-6471

CVSS v3

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 8/13/2026

Reference Information

CVE: CVE-2026-6471